
 

 

 

SESSION 2 
On an Alien Planet 
In this session, students continue animating their space adventure. They create 

two scenes using frame by frame animation. To start, they create the planet 

surface that shows grass growing and a flower blooming. Afterwards, they apply 

their new skills to make a hovercraft drive over bumpy terrain. The session ends 

with students selecting an Animation Challenge and creating it using Frame by 

Frame Animation. 

Assignment 6: What is Frame by Frame Animation? 

Assignment 7: Create Scene 2 – The Planet 

Assignment 8: Create Scene 3 – The Hover Craft 

Assignment 9: (Optional) Frame by Frame Challenge 

 

Session 2 Review: About Frame by Frame Animation 

Session 2 Skill Review: Tail Wagging 

Session 2 Extension Activity: Using Layers 

 

  

This TechnoKids project 
consists of 8 sessions, 
which are divided into 
separate assignments. An 
assignment is an activity 
that takes about 20 
minutes to complete. 

Learn more about TechnoFlash 
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Session 2: On an Alien Planet 

Getting Started 

Overview 

In this session, students continue animating their space adventure. They create two scenes using frame by 

frame animation. To start, they create the planet surface that shows grass growing and a flower blooming. 

Afterwards, they apply their new skills to make a hovercraft drive over bumpy terrain. The session ends with 

students selecting an Animation Challenge and creating it using Frame by Frame Animation. 

 

Materials 

 Flash CS5 

 Flash Flashcards (optional) 

o Tools Panel 

o Timeline Area 

o Layer Area 

 Flash Folder 

o Out of this World sample 

 Session 2 Review: About Frame by Frame Animation 

 Session 2 Skill Review: Tail Wagging 

o Tail.swf sample 

 

 

Teacher Preparation 

(Refer to the Preparing to Teach section of this guide for instructions) 

 Make the Flash folder available to students.  

 (Optional) Gather the flashcards listed in the materials list for this session.  

 

Teaching Strategy 

 

In this session, students learn about frame by frame animation. Explain scenario to students. 

 

In this session, you are going to animate using frame by frame animation. Frame 

by frame animation is used to move an object from one position to another, by 

creating content in EVERY frame. Although creating this type of animation does 

take time, it is a great way to gain control over how an object will move across 

the stage.  

 

Let's create the way animators did in the past, by creating an animated 

sequence one frame at a time. To become good at making frame by frame animation you need 

to create it more than once. For this reason, you will animate grass growing, hover craft driving, 

sign and waving creature. 

 

  

For every session, the 
Teacher Guide features an 
Introduction with a 
materials list, preparation 
advice, teaching strategies, 
lesson plans for each 
assignment, and learning 
objectives for the session. 
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Assignment 6 What is Frame by Frame Animation? 

 

In this assignment, students learn about frame by frame animation. This type of animation places content in 

EVERY frame of the Timeline in a keyframe. To gain an understanding of how each frame has different 

content, students study a sample document to notice the use of frame by frame animation. 

 

Introduce the following terminology: 

 

 Frame by Frame Animation: Frame by frame animation has the content of every frame change, by 

placing content in every frame of the Timeline into a keyframe. 

 

Emphasize the difference between a keyframe and a blank keyframe. A blank keyframe does not copy 

the content of the previous frames and is empty. A keyframe does copy the content of the previous 

frames. 

 

 

Assignment 7 Create Scene 2 – The Planet 

 

In this assignment, students create a scene that has the alien standing on his planet with the grass growing 

and flowers blooming. The action is created using frame by frame animation. You may wish to model the 

steps of making a frame by frame animation before students begin the assignment. 

 

 

Assignment 8 Create Scene 3 – The Hover Craft 

 

In this assignment, students create a scene that has a hover craft drive over bumpy terrain. You may wish 

to review the steps of making frame by frame animation before students begin the assignment. 

 

 

Assignment 9 (Optional) Frame by Frame Animation Challenge 

 

This is an optional assignment. Students should complete this assignment, based on their needs. If time is a 

factor, then this assignment can be skipped. However, if students are struggling to understand frame by 

frame animation, or are looking for an extra challenge, this assignment offers two fun activities. One is a 

sign with letters that change color, and the other is a rock creature that waves at the hover craft. 

 

  

This section, for teachers, 
explains each assignment 
and gives helpful tips. 
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Lesson Plan 

Assignment 6 - What is Frame by Frame Animation? 

 Read about frame by frame animation and then answer questions. 

 Study frame by frame animation by viewing the Out of this World sample. 

 

Assignment 7 - Create Scene 2 – The Planet 

 Open the Flash document. 

 Insert a new scene. View the scenes in the document. 

 Insert the alien from the Library onto the stage for Scene 2.  

 Animate the Ground: Draw a short line using the Pencil tool, to make a portion of the ground. Insert 

a keyframe into Frame 6. Draw another short line and add another keyframe. Continue until the 

ground stretches across the stage. 

 Draw the Grass: Draw the blade of grass using the Pencil tool. Insert a keyframe into the frame 

beside the last keyframe in the Timeline. Draw another blade of grass and insert another keyframe 

in the next frame. Continue to draw blades of grass and add keyframes until the grass reaches 

across the entire stage. 

 Draw a Flower Blooming: Use frame by frame animation to draw a flower stem, leaf, and petals, 

with each appearing one after the other in its own keyframe. 

 Add the text to describe the action. Solve the problem of how to make the words appear at the 

SAME TIME as the action (Solution: place it on its own layer). 

 Insert a new layer and rename it Words. Cut the words from Layer 1 and paste them onto the 

Words layer. 

 Save the Flash document and then close the program. 

 

Assignment 8 - Create Scene 3 – The Hover Craft 

 Open the Flash document. 

 Insert a new scene. 

 Rename Layer 1 to Hover Craft. 

 Draw the planet surface. 

 Draw the hover craft and group the object. 

 Animate the hover craft using frame by frame animation to have it drive over the bumpy terrain by 

moving up and down across the stage. 

 Add words to describe the action on a new layer. 

 View the story. 

 Save the Flash document and then close the program. 

 

Assignment 9 - (Optional) Frame by Frame Animation Challenge 

 Open the Flash document and display Scene 3. 

 Select from two challenges: planet sign or waving rock creature. 

 Save the Flash document and then close the program. 

  

The Lesson Plan lists the 
individual steps in each 
assignment. 
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Learning Objectives 

Students should be able to complete each learning objective independently. 

 

Content Knowledge: 

 define frame by frame animation 

 understand the difference between a blank keyframe and keyframe 

 

Technical Skills: 

 

Operating Environment 

 open and close a program 

 save a document 

 

Animation 

 insert a new scene 

 view scenes in a document 

 insert an object from the symbol Library 

 select a frame 

 insert a keyframe 

 animate an object using frame by frame animation 

 view the animation using the ENTER key 

 insert and rename a layer 

 cut an object 

 paste an object in the same position as the copied item using Paste in Place 

 test the movie in the preview window 

 

Graphics 

 add text and customize the properties 

 draw objects and customize their appearance 

 

Applied Technology 

 analyze frame by frame animation within a movie clip 

 animate a space adventure using frame by frame animation 

 

 

 

 

Learning Objectives are 
specified for each session 
in this project. A checklist 
of all objectives is provided 
at the end of the project in 
Session 8. 
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Assignment 6: What is Frame by Frame Animation? 
 

In this assignment, you learn about frame by frame animation.  

 

 

What is Frame by Frame Animation? 

Frame by frame animation uses keyframes in EVERY frame of the Timeline. A keyframe 

copies the content from the previous keyframe. The keyframes in frame by frame 

animation are placed right beside each other. Slight changes are then made to the 

objects in each frame. These changes are seen as movement, when the animated 

sequence is played.  

 

 
 

 

 

 

 

Frame by frame animation is a lot like what animators used to do in the past. Before there were computers, 

animators used to draw the character in a new position, one frame at a time. To create animation using 

this technique is a time consuming task, however, it does offer lots of control over how the object moves.  

 

 

 

 

Questions about Frame by Frame Animation 

1. What is frame by frame animation? 

  

 Animation that is created by placing a keyframe in EVERY frame, with slight changes made to the 

content of each keyframe. 

 

 

 

2. Frame by frame animation uses keyframes. How is a keyframe different from a blank keyframe? 

  

 A blank keyframe is empty, whereas a keyframe copies the content of the previous keyframe. 

 

A keyframe is placed into every 

frame of the Timeline. 

Introductory information can 
be used for classroom 
discussions prior to using 
the computer. Students 
answer questions for 
comprehension. 
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Study the Frame by Frame Animation 

You are going to watch the Out of this World sample. Two scenes use Frame by Frame animation. Answer 

the questions about each scene. 

 Open the Flash folder. You may need to ask your teacher where this is located. Double click the Out 

of this World document to watch the animated story. 

 

The Alien 

  

3. What different events occur in each frame of the animation? 

  

 

 

 

The grass gradually grows and the 

flower blooms. 

 

 

 

The Hover Craft 

  

4. How would you describe the animation of the hover craft in this scene? 

  

 

 

 

It is choppy and slow. 

 

 

 Close the file. 

 

Students critically analyze a 
sample file before creating 
their own animation. 
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Assignment 7: Create Scene 2 – The Planet 
 

In this assignment, you are going to continue to create an animated space adventure. You will add a new 

scene to the space story you have already started. 

 

Follow the instructions to: 

 

1. Add a new scene. 

2. View each scene in the story. 

3. Insert the alien from the Library. 

4. Animate the ground appearing using frame by frame animation. 

5. Animate grass growing using frame by frame animation. 

6. Animate a flower blooming using frame by frame animation. 

7. Add text to describe the scene. 

8. Insert a new layer and place the text onto this scene. 

 

Open the Flash Document 

 Open the document in Adobe Flash. The document opens up to show the last scene you were 

editing. In this case, the scene in view should be Scene 1. 

 

Insert a New Scene 

When making an animated story with Flash it is a good idea to divide the events into scenes. Each scene 

has its own stage, Timeline, and layers. You are now going to insert a new scene. 

 From the Insert menu, select Scene. 

- A new stage opens in the window. It has an empty Timeline. You will notice that the Scene Number 

reads Scene 2. 

 

 
 

View each Scene in the Story 

 Scene 1 has not been deleted. It is still part of the animated story. You can easily switch from Scene 2 

to Scene 1 and back again. Try it! 

 Click the Edit Scene arrow and from the list click Scene 1. 

 Now click the Edit Scene arrow again and this time select Scene 2. 

  

In the previous session, 
students started an 
animated space adventure. 
In this assignment, they 
add a new scene. 
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Insert the Alien Symbol from the Library 

In the previous session, you created an alien and placed it into the Library. The 

Library lets you use the same object, over and over again without needing to 

redraw it. You are now going to insert the alien from the Library. 

 From the Window menu, select Library. 

 Click on the alien symbol and drag it onto the stage. 

 

 Make sure that the alien is not selected by pressing ESC on the keyboard. 

 

Draw the Ground using Frame by Frame Animation 

You are going to have the ground gradually appear underneath the alien using frame 

by frame animation. Unlike the previous session, when you used blank keyframes, this 

time you are going to use keyframes. The difference between the two is that a 

keyframe copies the content of the previous frames into the new one. This means 

everything you drew before the keyframe remains on the stage, whereas a blank 

keyframe is empty. 

 

Draw a Short Line 

 Click the Pencil tool.  

 Click the Properties tab to view the Property Inspector.  

Select a stroke color, width, and style. 

 Now pick the type of line from the Tool Options in the Tools Panel.  
HINT: Try Smooth. 

 
TIP: Make sure that Object Drawing is turned OFF.  

 Starting from the left side of the stage, draw a short line. 

 
  

Draw a short line for 

the ground. 

Tools are enlarged to make 
them easy to find. 
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Add a Keyframe 

 Right click on frame 6 in the Timeline. From the menu, select Insert Keyframe. 

or 

Press F6 on the keyboard. 

 

Draw Another Short Line and then Add Another Keyframe 

 Draw another short line, begin it where the last line ended. 

 Right click on frame 12 in the Timeline. From the menu, select Insert Keyframe,  

or press F6. 

 

View the Animation 

 Watch the animation by pressing the ENTER key. Notice that it appears very choppy. 

 

Complete the Ground 

 Continue to draw short lines and add keyframes to the Timeline until the ground reaches across the 

entire stage. 

- Your window may look something like this: 

 

 
 

 

 

  

You should have many 

keyframes in the Timeline. 

Frame by frame animation looks the best 

when there is a new action in EVERY frame. 

When the ground appears it looks choppy. 

This is because there are several frames 

between keyframes.  

 

You are now going to make grass grow. This 

time there will be a keyframe in each 

consecutive frame. You will notice a big 

difference in the smoothness of the 

animation. 

Illustrated step-by-step 
instructions teach students 
how to add keyframes. 
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Draw the Grass using Frame by Frame Animation 

Follow the instructions to make the grass grow one blade at a time. 

 

Draw a Blade of Grass 

 Click the Pencil tool .  

 From the Property Inspector, select a stroke color, width, and style. 

 Now pick the type of line from the Tool Options in the Tools Panel. HINT: Try Smooth. 

 Draw a blade of grass near the left side of the stage coming up from the ground. 

 

Add a Keyframe 

 Click on the frame beside the last keyframe in the Timeline. Right click the mouse and select Insert 

Keyframe or press F6 on the keyboard. 

 
 

 

 

 

Draw Blade of Grass and then Add Another Keyframe 

 Draw another blade of grass. 

 Click on the frame beside the last keyframe in the Timeline. Right click the mouse and select Insert 

Keyframe or press F6 on the keyboard. 

 

View the Animation 

 Watch the animation by pressing the ENTER key. Notice that the grass grows quickly and the 

animation is smooth. 

 

Complete the Grass 

 Continue to draw blades of grass and add keyframes until the grass reaches 

across the entire stage. 

- Your Timeline may look something like this: 

 
 

  

Ground Appearing Grass Growing 
Each frame should be a keyframe. 

 
Add a keyframe right beside the last keyframe in the Timeline. 

Instructions include tool 
icons, sample window 
views, and helpful tips. Sam
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Draw a Flower Blooming using Frame by Frame Animation 

Follow the instructions to make the flower grow. To start you will animate the stem and then some leaves. 

After that the center of the flower will appear, with one petal at a time blooming. 

 

 Click the Pencil Tool and then select the options. 

 TIP: Make sure that Object Drawing is turned OFF.  

 Draw a stem. 

 Click on the frame beside the last keyframe in the Timeline. Right click the mouse and select Insert 

Keyframe or press F6 on the keyboard. 

 Draw a leaf onto the stem using the Pencil Tool.  

 Select the Paint Bucket Tool . Select a fill color.  

HINT: From the Tool Options set the Gap Size to Close Large Gaps. 

 Fill the leaf shape with color.  

 Click on the frame beside the last keyframe in the Timeline. Right click the mouse and select Insert 

Keyframe or press F6 on the keyboard. 

 Using the Pencil Tool draw the center of a flower. Fill it with color. 

 Click on the frame beside the last keyframe in the Timeline. Right click the mouse and select Insert 

Keyframe or press F6 on the keyboard.  

 Using the Pencil Tool draw a petal. Fill it with color. 

 Click on the frame beside the last keyframe in the Timeline. Right click the mouse and select Insert 

Keyframe or press F6 on the keyboard. 

 Continue to draw petals and add keyframes until the flower has bloomed. 

- Your picture may look something like this: 

 
  

TIP: To delete a keyframe 

right click on the frame in 

the Timeline and select 

Remove Frames. Sam
ple
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What is the Problem? 

 

 Click on Frame 1. Use the Text Tool to type the words:  

The alien looked around him. Each day was the same. The grass grew and the 

flowers bloomed. He wanted to see something different. 

 Watch your story by selecting frame 1 and pressing ENTER. Do you notice the 

problem? 

 

1. What is the problem? 

  

 The words disappear after the first frame. 

 

 

 

 

Solve the Problem: Add a New Layer 

Right now, the words in Frame 1 are only on the screen for one frame. Had the words 

been added to Frame 1 before all the keyframes were added, it would be on the 

screen the entire time. This is because a keyframe copies the contents of the previous 

frame into the new one. This means if it would have been added first, it would have 

been copied into each keyframe.  

 

However, the words were not added first and the problem now exists. There is a need 

to solve the problem. One of the easiest solutions is to put the words on another layer.  

 

Each layer has its own row in the Timeline. This means that you can have different 

events occurring at the same time by placing objects on different layers. By placing 

the words on a new layer the words can be displayed the entire time the animation is occurring on Layer 1.  

Try it! 

 

Follow the instructions to: 

 

 insert a layer 

 name the new layer Words 

 paste the words from Layer 1 onto the newly created Words layer 

  

You need to add the text: The alien looked around him. Each day was the same. 

The grass grew and the flowers bloomed. He wanted to see something different.  

 

You want the viewer to be able to read the words at the SAME TIME as the action is 

occurring on the screen. However, there is a problem! 

Helpful tips throughout the 
assignment ensure success 
and assist in 
troubleshooting. 
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Add a New layer 

 Click New Layer at the bottom of the Layers area of the Timeline. 

 

Study the Layer Area 

Take a minute to study the layer area. Notice how a new layer has now been added above Layer 1. It has 

a pencil beside it. This indicates the layer you are currently editing. The eye icon lets you show or hide a 

layer, the lock icon lets you set the layer so that no edits can be made and the rectangle displays the layer 

as an outline or solid, much like a coloring book. 

 

Rename a Layer 

It is a good idea to name a layer to tell about what types of objects are on it. You are going to rename 

Layer 2 to Words. 

 Double click on Layer 2. Type Words. 

 

Cut an Item from Layer 1 into the Words Layer 

You now need to cut the words from Layer 1 and paste them onto the Words Layer. 

 Click on Layer 1. Notice the pencil has moved. 

 Select Frame 1 in the Timeline. 

 On the canvas, right click on the text box in Frame 1. From the options, select Cut. 

 Click on the Words Layer. Right click on the stage and select Paste in Place. 

 

Make the Words Appear at the Same Time the Action Occurs 

 Press ENTER to play the scene.  

Notice the words are in view the entire time that the action occurs. This is because Flash automatically 

inserts a keyframe in the same location as the final frame in the first layer. Study the Timeline to notice the 

change. The frames in the Words Layer are grey with a keyframe at the end. 

 
 

 

  

lock or unlock layer 

show or hide layer show layer as outline or solid 

layer name 

layer indicator 

NOTE: If the program does not automatically place the words into the frames, then you can do it manually. To do this, add a keyframe to the Timeline in 

the Words layer that is the same frame number as the keyframe that contains the final action in Layer 1.  In the example above it is frame 100. 

Students are challenged to 
explore Flash tools. 
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Save the Flash Document 

 From the File menu, select Save. 

 

Close the Program 

 From the File menu, select Exit. 

 

 
 

 

Questions about using Frame by Frame Animation 

 

2. How does the animation change when keyframes are placed in EVERY frame, instead of 

spaced apart in the Timeline? 

 

The animation is smoother when the keyframes are beside each other. 

 

 

 

 

 

3. List two ways that frame by frame animation is different than static animation: 

 

 In static animation still pictures are shown on the screen. However in frame by 

frame animation the objects move across the screen.  

 

 In static animation blank keyframes are used, where as in frame by frame 

animation keyframes are used. 

 

 

 

 

4. What did you learn that you did not know before? 

For the paperless 
classroom, students can 
answer the questions in 
their digital workbooks 
using the latest version of 
Adobe Reader. The Teacher 
Guide includes answers. 
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Assignment 8: Create Scene 3 – The Hover Craft 
 

You are going to apply what you know to make a new scene that shows the alien driving in his hover craft. 

You will use frame by frame animation to show it going over the bumpy terrain. 

 

 
 

Open the Flash Document 

 Open the document in Adobe Flash. The document opens up to show the last scene you were 

editing. In this case the scene in view should be Scene 2. 

 

Insert a New Scene 

 From the Insert menu, select Scene. 

 A new stage opens in the window. It has an empty Timeline. You will notice that the Scene Number 

reads Scene 3. 

 

Create the Hover Craft and then Animate the Object 

 Double click Layer 1 and name it Hover Craft. 

 On the Hover Craft layer draw the planet surface. 

 
 

 

 

 

 

 

  

Are you having trouble filling in the objects that you 

have drawn with color?  

 
Try this: 
1. Click the Rectangle Tool.  

2. Turn the Object Drawing option OFF. 

3. Select the SAME stroke and fill color.  

4. Draw a rectangle.  

5. Select the Pencil Tool.  

6. Turn the Object Drawing option OFF. 

7. Change the stroke color to the same color as 

the rectangle.  

8. Place the pencil on the edge of the rectangle 

and start to draw a bumpy line.  

9. End the line, by touching the edge of the 

rectangle.  

10. Select the Paint Bucket Tool. 

11. Select Close Large Gaps as the Gap Size in the 

Options Tray. 

12. Fill the area with color. 

Checklists help students 
make sure that all parts 
of the task are complete. 
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 Draw a hover craft and group all the objects together to form on large object. 

 

 Drag the hover craft to its starting point on Frame 1. Put it slightly off the stage. 

 Add a keyframe to Frame 2 by selecting the frame and then pressing F6 on the keyboard. 

 Click on the canvas to deselect all objects. 

 Click on the hover craft to select it. Make sure the terrain is not selected.  

 Move the hover craft up and to the right.  

 Add a keyframe to Frame 3.  

 Click on the hover craft to select it. Move it down and to the right. 

 Continue to do this until the hover craft moves across the stage, looking as if it is driving over the 

bumpy terrain. 

 

Add Words to Describe the Action on a New Layer  

 Click New Layer at the bottom of the Layers area of the Timeline. 

 Rename the new layer, Words. 

 On the Words layer, click on Frame 1.  

 Use the Text Tool to type the words: 

He got into his hover craft and drove to the launch pad. 

 
 

Test the Movie 

 From the Control menu select Test Movie. Select Test. 

If you receive a warning message, click OK. 

 Watch the story.  

 Click the Close button to exit the preview pane.  

 

Save the Flash Document and Close the Program 

 From the File menu, select Save. 

 From the File menu, select Exit. 

How to Group Objects: 

1. To group the objects, click the 

Selection Tool. 

2. Click and drag around the 

hover craft. 

3. From the Modify menu, select 

Group. 

Troubleshooting:  

If your scene goes by too 

fast, add more keyframes. 

Tips and suggestions 
encourage creative thinking. 
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Assignment 9: (Optional) Frame by Frame Animation Challenge 
 

You have learned how to animate objects frame by frame. Below are two Animation Challenges. Pick one 

and try it! 

 

Open the Flash Document and Display Scene 3 

 Open the document in Adobe Flash. The document opens up to show the last scene you were 

editing. In this case, Scene 3.  

 

If it does not, click on the Edit Scene tool and select Scene 3 from the list. 

 

Frame by Frame Animation Challenge 1: Planet Sign 

In this challenge, you apply what you know to make a sign that reads the planet name. Using frame by 

frame animation the color of the letters will change. 

 

Steps 

1. Click New Layer  at the bottom of the Layers area.  

2. Rename the layer Sign. 

3. Draw a sign using the drawing tools. 

    
4. Use the Text Tool to add the planet name to the sign. 

5. Right click on the text box. Select Break Apart to ungroup the name into individual letters. 

 

6. Place a keyframe in Frame 2 of the Sign layer by selecting the frame and then pressing F6 on the 

keyboard. 

7. Change the first letter to another color: 

 a. To do this, click on the canvas to deselect all objects.  

 b. Select the first letter using the Selection Tool.  

 c. Select a color from the Fill Control.  

 

8. Place a keyframe in Frame 3 of the Sign layer. 

9. Click on the canvas to deselect all objects. Change the next letter to another color. 

10. Continue to add keyframes and change the letter color until all the letters have changed. 

11. You can copy the animation you have just created to have it repeat itself: 

 a. Click on the last keyframe in the Sign layer. Hold the SHIFT key and click Frame 1. 

 b. Right click on the selected frames and select Copy Frames from the menu. 

 c. Right click inside the next blank frame in the Sign layer. Select Paste Frames. 

 d. You can keep pasting the frames, by right clicking on the next blank frame and then 

selecting Paste Frames from the menu.  

 e. When you paste the frames you may find that there are now extra frames in the Timeline, 

which are causing the sign to display longer than the Hover Craft and Word layers. To solve 

this problem, select the extra frames in the Sign layer. Right click on the selection and select 

Remove Frames from the menu. 

 

 

This optional assignment 
teaches advanced animation 
skills. Illustrated step-by-
step instructions make 
creating scenes easy! 
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Frame by Frame Animation Challenge 2: Wave Goodbye 

In this challenge, you apply what you know to make an alien rock creature that waves  

good-bye. Using frame by frame animation you make his arm move. 

 

Steps 

1. Click New Layer at the bottom of the Layers area.  

2. Rename the layer Wave. 

3. Draw a rock creature using the drawing tools. 

 

4. If the arm and hand are not grouped together, group them. 

 

5. Place a keyframe in Frame 2 of the Wave layer by selecting the frame and then pressing F6 on the 

keyboard. 

6. Move the registration point: 

 a. Click the Free Transform Tool.  If necessary, deselect all the objects by clicking on the 

stage away from the rock or arm. Click on the arm to select it.   

 b. Click on the registration point: it is the round circle inside the bounding box. Drag it to the 

point where you want the arm to pivot (at the body). 

 
 

7. Rotate the arm slightly downwards. 

8. Place a keyframe in Frame 3. 

9. Click on the canvas to deselect all objects. Rotate the grouped arm downwards. 

10. Continue to add keyframes until the arm has moved down. 

11. You can copy the animation you have just created to have it repeat itself: 

 a. Click on the last keyframe in the Wave layer. Hold the SHIFT key and click Frame 1. 

 b. Right click on the selected frames and select Copy Frames from the menu. 

 c. Right click inside the next blank frame in the Wave layer. Select Paste Frames. 

 d. You can keep pasting the frames, by right clicking on the next blank frame and then 

selecting Paste Frames from the menu.  

 e. When you paste the frames you may find that there are now extra frames in the Timeline, 

which are causing the sign to display longer than the Hover Craft and Word layers. To solve 

this problem, select the extra frames in the Wave layer. Right click on the selection and 

select Remove Frames from the menu. 

 

 

Save the Flash Document and Close the Program 

 From the File menu, select Save. 

 From the File menu, select Exit. 

 

 

registration point registration point 
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Session 2 Review: About Frame by Frame Animation 
 

Match the tool to its function. 

 

1. D 

 

A. Add text to the stage. 

 

 

2. A 

 

B. Add a layer. 

 

 

3. E 

 

C. Select a scene to edit. 

 

 

4. C 

 

D. Rotate, skew, or scale a selected object. 

 

 

5. B 

 

E. Draw freehand. 

 

 

/5 

 

Match the term to its definition 

 

 

6. B frame by frame animation A. A gallery of stored objects 

 

 

7. C scene B. Animation that has a keyframe in every frame 

 

 

8. E Timeline C. A part of a Flash document that contains its own 

stage, Timeline, and layers  

 

9. D keyframe D. A frame in an animated sequence that contains 

drawn objects  

 

10. A Library E. Made up of layers and frames, it organizes and 

controls a document's content over time  

 

11. F frame F. A single unit in a Timeline 

 

 

12. G layer G. A division of the Timeline into parts that allow objects 

to be stacked on top of each other  
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Review lessons at the end 
of sessions provide 
activities to check and 
reinforce newly learned 
skills, concepts, and 
terminology. 
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Answer the questions. 

 

13. What is the difference between a keyframe and a blank keyframe? 

 A blank keyframe is empty, whereas a keyframe copies the content of the previous frames. 

  

 /1 

  

14. What keyboard key will add a keyframe to the Timeline? 

 F6 

  

 /1 

15. What keyboard key will play the Timeline? 

 ENTER 

  

 /1 

16. Why is it a good idea to give layers specific names? 

 It makes it easier to recognize the content of the layer.  

  

 /1 

  

  

 

 

TOTAL: /16 
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Session 2 Skill Review: Tail Wagging 
 

Frame by frame animation can be used to animate objects one frame at a time using keyframes. Apply 

your knowledge to create a creature that has a wagging tail. 

 

1. Open Flash. Click the File menu and select New.  

Select ActionScript 3.0 as the file type. Click OK. 

2. Rename Layer 1 to Creature. 

3. Draw a creature using the drawing tools. DO NOT INCLUDE A TAIL. 

 
4. Group the creature: 

 a. Select the Selection Tool.  Click and drag to draw a box around the creature. 

 b. From the Modify menu, click Group. 

5. Position the creature on the stage. 

6. Draw a tail. If the parts of the tail are not grouped, group them.  

7. Position the tail so it looks like it is attached to the creature. 

 If necessary, change the object order. Right click the tail. From the menu, select Arrange. Click Send to Back. 

8. Place a keyframe in Frame 2 of the Creature layer by selecting the frame and then pressing F6 on 

the keyboard. 

9. Move the registration point: 

 a. 
Click the Free Transform Tool.  

 b. Click on the registration point, it is the round circle inside the bounding box. Drag it to the 

point where you want the tail to pivot (at the body). 

 

7. Rotate the tail slightly downwards. 

8. Place a keyframe in Frame 3. 

9. Click on the canvas to deselect all objects. Rotate the tail a bit more. 

10. Continue to add keyframes until the tail has moved down. 

11. You can copy the animation you have just created to have it repeat itself: 

 a. Click on the last keyframe in the Creature layer. Hold the SHIFT key and click Frame 1. 

 b. Right click on the selected frames and select Copy Frames from the menu. 

 c. Right click inside the next blank frame in the Creature layer. Select Paste Frames. 

 d. You can keep pasting the frames, by right clicking on the next blank frame and then 

selecting Paste Frames from the menu.  

12. IF you find that the tail moves too fast, you can adjust the frames per second. Click the Frame Rate 

Indicator at the bottom of the Timeline. Change the number to 12 fps. 

13. Save the file as tail. 

14. Exit Flash. 

 

 

  

registration point registration point 

Skill Reviews are activities 
for students to practice 
the technical skills learned 
in the previous session. 
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Session 2 Extension Activity: Using Layers 
 

A layer is a row in a Timeline. Follow the instructions, to learn the parts of the layer area, as well as how to 

insert, rename, move, delete, hide, lock, and change the view of layers. 

 

About the Layer Area 

 

The layer area contains each layer stacked one top of each other, as well as tools for managing the layers. 

Label each part of the layer area: 

 

4 layer name  8 layer indicator  2 lock or unlock layer 

        

1 show or hide layer  3 show layer as outlines  7 delete  

        

5 new layer  6 new folder    

 

 
 

How to Rename, Add, and Adjust the Stacking Order of Layers 

 

1. Open Flash. Click the File menu and select New.  

Select ActionScript 3.0 as the file type. Click OK. 

  

2. Double click Layer 1 and rename it Circle. Draw on it a circle using the Oval Tool.  

  

3. Add a layer, by clicking the New Layer button. Rename it Square.  
 

   

4. Draw on it a square placing it directly over top of the circle. 
 

  

5. Click on the Square layer. Drag it down below the Circle layer.  

  

 

What happens? The square moves behind the circle. 

 

 

  

Extension Activities at the 
end of a session provide 
optional enrichment 
challenges. 
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Change the View of a Layer from an Outline to Solid 

6. Change the objects on each layer to an outline of the shape by clicking on the Show Layer 

as Outlines square in the layer. Click it again to return it to a solid.   

  
 

 

Hide or Show a Layer 

7. Click on the Square layer. Hide it from view by clicking on the Show or Hide Layer dot. Click 

on the X to show the layer.  

  
 

 

Lock and Unlock a Layer 

8. Click on the Circle layer. Lock it so that no changes can be made, by clicking on the Lock or 

Unlock Layer dot. Now try to draw something on the layer – you cannot!  

 

 

 
 

 Unlock the layer, by clicking on the Lock or Unlock Layer dot again. 

  

 

 

Delete a Layer 

9. Click on the Square layer. Click on the Delete tool to erase it. 
 

 

 

 

Questions about Layers 

10. How do you know what layer is "active"? 

  

 It turns blue and has a pencil. 

 

 

11. Why would you want to lock a layer? 

  

 To prevent changes from being made to objects on the layer. 

 

 

12. Why would you want to change the position of a layer?  

  

 To change the stacking order of the layers.  

 

 

 Sam
ple




